PS2 Emulator for Mac OS 10.8+ - How To (PCSX2 Tutorial)

Channel: Petes


TIP: Right-click and select "Save link as.." to download video

Initializing link download... Initializing link download.....

How to get PCSX2 ( PS2 ) emulator running on Mac OSX. I can only confirm that it does work on 10.8+.. it may work on older versions but i have no way of testing that..

XQuartz :
ISO's/Roms :
Bios :
x11 (version of xQuartz for older mac versions) :

Common Questions:

Q. I followed the video in the order you did it and then noticed the annotation telling me to install xquartz first, how do I uninstall the .pkg files that I installed first so I can start from scratch?
A. Delete all the files and download them again.. then just repeat the process of installing them in the right order and it should work.

Q. Why do you need to download the other bios folder and what do you do with it?
A. That is a mistake. I forgot you got a bios file already in the PCSX2 download. You can use either bios file.

Q.When clicking on the PCSX2 application, it bounces and closes..
A. Restart your computer and the next time you open PCSX2 it will work.

Q. The sound isn't working.
A. When u go to configure, the "sound" one that needs to be on zero etc, hit configure underneath it, for some reason the mute box is checked. Uncheck it.

Q.I'm getting it to go to the opening animation but it keeps telling me to put in a playstation 2 format disk even though i have an iso downloaded and selected.
A. The file you have is probably the compressed file and not the .iso. You will need to extract the file. It is probably a .7z, .bin or .zip. These can be extracted with free softwares which you can find by searching google.

Q.It keeps saying this to me every time i load up the iso:
"Offset 0xea0fccf0 invalid. Legit SIGSEGV. Aborting. line 2: 2381 Segmentation fault: 11 .pcsx2"

For anybody who has a "segmentation error", before you start a .iso or anything, go to config - cpu then turn off the EErec. This will start up the game but it'll running on extremely low FPS. But once you begin the game and start seeing images press esc and go back to config - cpu then turn on EErec. Press okay and then go to run - execute and everything should be back to normal FPS